This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.


I have to admit that I missed out the fujifilm x-t10 giveaway at the last convention when they are the diamond sponsors...
With Microsoft being the diamond sponsor this round, and the recent announcement of surface book for creative professionals.. do you think the surface books will be given.. <sic> ... Free for attendees? Haha.. (one can't stop dreaming right)
Views: 8 / Likes: 0 / Replies: 0


Views: 12 / Likes: 0 / Replies: 0
Things have gone into deep autumn mode here on the south-western Saskatchewan prairie. The colourful leaves are mostly gone and the landscape is largely one of dull browns and yellows. Still, I love it.



Views: 16 / Likes: 1 / Replies: 0
Views: 18 / Likes: 0 / Replies: 0
Hi guys. I suddenly can't focus with the remote camera app. The camera is in AF-mode (I am using X-Pro 2) and I have done this several times before without problems. I even resetted all the settings on my camera, and re-downloaded the app to my iPhone 5. I hope someone can help me out there!
Views: 23 / Likes: 0 / Replies: 0
Views: 35 / Likes: 0 / Replies: 0
I bought a new car navigation system which has a slot for micro sd cards, for programs, so I inserted a spare card, Lexar 16gb, which I had in my bag. A few hours later I touched the screen next to the card slot and it was hot, really hot. I ejected the card which as too hot to handle and dropped it on the floor. I was about to remove the system to return, but I decided to try another card, sandisk 64gb, this was absolutely fine.
I've used the Lexar card in other applications and don't remember any problems in the past, but then it hasn't been working for hours at a time.
Has anyone else noticed cards getting hot.
Views: 24 / Likes: 0 / Replies: 0
anyone else having problems using the fuji film app/wifi with their xt-2? never had issues with the xt-1. using a samsung s6 with all updates for phone and camera (until the new firmware today). i get the "problem connecting" message on my phone. it looks like the phone recognizes and starts using the cameras wifi but then immediately shuts the link down. any help would be greatly appreciated. thanks. Craig
Views: 36 / Likes: 0 / Replies: 0
Any recommended camera stores in Wellington, NZ to get my X-T2 sensor cleaned this Saturday?

Views: 97 / Likes: 0 / Replies: 4
Xe-2 body with the 56mm. Processed in Lightroom and NIK Silver EFX.
Emmy Sue BW2.JPG
Views: 95 / Likes: 5 / Replies: 2
0.5 sec,f/2.8,ISO 400

LR-1838 copy.png
Views: 90 / Likes: 6 / Replies: 1
X-E2. 60mm.


Views: 75 / Likes: 2 / Replies: 1
Fall colors at the Seattle Japanese Garden.

Views: 117 / Likes: 8 / Replies: 5
One of my favourite views of Chichester Cathedral, taken from the side that isn't on a road/busy public thoroughfare.

X-T1 and 16mm

Views: 99 / Likes: 4 / Replies: 4
Hello All,

I am looking for some help on microphones for when I do video. I'm not a professional or doing professional video just augmenting the video I take of the family.
The Fuji has a smaller jack (smaller than 3.5mm) and my current microphone (a lavalier) has a 3.5mm jack. So I haven't been able to use it.

What are your suggestions? I can get an adapter (I can use some help finding one as the one I found on amazon came with the wrong size so I could use a recommendation)

I have been looking at Rhode microphones but it is unclear whether they will work with the X-Pro2 Jack.
OR is there a fuji option?

Views: 103 / Likes: 0 / Replies: 5
Hello all,
In one of the last x-stories posted, fujifilm compares those two lenses as well as the 23mm in the x100 series.

About the 23mm f1.4 they say: "XF23mmF1.4 renders dynamic image with added depth". What are they talking about? can anyone explain me, please?

About the new 23mm f2.0 they say: "XF23mmF2 renders images with lots of information, which is a plus for snapshooters". same question here, what do they mean by lots of information? is it about tonal rendition?

Please, help, I can't understand them.
Thanks you
Views: 391 / Likes: 0 / Replies: 8
This guy is a local Personal Trainer and just won his first bodybuilding competition at the weekend. He'd booked the shoot to fall just two days after the comp, so he'd be in great condition.
X-Pro2 with 50-140mm f2.8, 2 Godox AD360's with either a gridded strip soft box or 120cm octabox as key light and snoot or gridded standard diffuser as backlight. Shot using Acros emulation mode and given one of my own wee tweaked presets in Lightroom.

KSG73138-Edit.jpg KSG73055.jpg KSG73082.jpg KSG73172-Edit.jpg
Views: 130 / Likes: 4 / Replies: 8

Views: 215 / Likes: 18 / Replies: 19
Searching eBay recently for a Fuji-mount macro lens, and came across this....60/2.8-22, manual focus, normal to 2x macro (twice life size, zowie), dimensions 95x70mm, weight 680 grams (ouch), US$238 but there are several offered, some more and some less.
Specs suggest a special internal mechanism to move the glass enough distance to focus from infinity continuously to 2:1 in what looks like a one-piece metal housing, and that may account for the weight.
My Konica Macro Hexanon 55/3.5 is a 2-piece lens, three counting the Fuji adapter, weighs 485 grams total and does infinity to life size, but not continuously, so this Chinese lens sounds interesting.
Comments, reviews?
Views: 126 / Likes: 0 / Replies: 4

Fujinon XF 27mm f/2.8 awesome!!!
Views: 289 / Likes: 1 / Replies: 9
Views: 105 / Likes: 5 / Replies: 5

XT2 and XF55-200mm yesterday at Clifton Gorge where I ran into another Fuji owner that recognized my camera. RAW and BW conversion done in PSCC 2015.5.

Thanks for looking,
Views: 62 / Likes: 2 / Replies: 1
I was wondering if anyone has any idea of what type of focal lens equiv. the TCL mounted on a X70 would give.
I understand that it would screw on since the lens diameter are the same as the X100 series.
my suspicion is that if the TCL on a 100 gives the FL of a 50mm then on a X70 it should give only something like a 35mm or so, anybody run a test or have feed back to share? thansk
Views: 100 / Likes: 0 / Replies: 1
The ski lodge at Lake Louise, Alberta, this past September. I used the Classic Chrome colour profile which I generally don't care for that much. The shot could have been a tad wider, but...

_DSF1567 copy-Edit.jpg
Views: 40 / Likes: 0 / Replies: 0
Views: 33 / Likes: 2 / Replies: 0

_DSF1493 copy-Edit.jpg


Views: 35 / Likes: 0 / Replies: 0
1. Floor of cedar forest (X-T10 + 14mm f/2.8)
2. Crevasse in rock face (7D + 70-300mm L)

_DSF1552 copy-Edit.jpg

Views: 40 / Likes: 1 / Replies: 0
Views: 333 / Likes: 0 / Replies: 12
IMG_0106.JPG EM10
Views: 44 / Likes: 0 / Replies: 0
After a year or more of use (should look up when I purchased the camera...can't remember,) an SD card got stuck n the slot. I managed to get it out. Now, SD card when inserted won't click in, but will read if I close the door over it.

Is this a common malady with the xt1? Any home cures known or do I have to send it to Fuji to be fixed?

Help and thanks.
Views: 193 / Likes: 0 / Replies: 3

My X20 died and costing the same as new X30 to fix it, ordered the X30 from T-dimension. Now they say no stock and it appears the same story across most retailers (amazon, adorama). Any suggestions for sourcing a new or as new /used X30?
Views: 141 / Likes: 0 / Replies: 4
Got another XT2 and the 56 1.2 today so I'm almost there in terms of replacing my Nikon kit with just a couple more lenses or three to get.
I have the 16, 56, 60mac and 90 at the moment, and will be getting the 50-140 and 10-24 and the 23f2 next.
So pretty much ready for work as a 3/4 Fuji Guy.

Only hold up really is the flash-on-camera situation at this point and while I don't use flash on camera all that often, when you need it, you need it and I certainly wouldn't go anywhere without one.
I bought the little Nissin i40 today thinking it would be a good pack/back-up flash for travelling light on the fishing stuff I do, but still want something properly beefy like the new 500 that's coming out soon. (maybe)
First testing with the i40 reveals it doesn't work beyond a tiny little bink of light in any settings.
After a bit of reading I see there's some issues with firmware and I might have jumped the gun ?

I did expect there might be glitches when buying a just released model so I'm not angry about this, but I do hope there's a fix in the works.
Views: 260 / Likes: 0 / Replies: 8
Thought I'd set myself a challenge, on my way to the dentist this morning I brought my X-T1 and chose the XF35mm and shot it wide open at f/1.4 for all these shots, here's what I came up with, nothing exciting really, just to see what I could photograph within thirty minutes.

All shot on 1:1 ratio with classic chrome selected and NO processing whatsoever, J-Peg only, kind of arty/abstract captures;

[​IMG]Hygienist suite by Macvisual Photography, on Flickr

[​IMG]Trolleys by Macvisual Photography, on Flickr

[​IMG]Tuned in by Macvisual Photography, on Flickr

Just a bit of fun and personal creativity.

Views: 63 / Likes: 0 / Replies: 1
5D3_2680.jpg 5D3_2681.jpg I never been a big fan or 56's supplied hood, so i bought 23's hood from a friend and I love it
Views: 342 / Likes: 0 / Replies: 21
I have never had problems updating either camera body or lenses before, but have run into a problem this time. I downloaded the updates from the Fuji site - version 3.11 from version 3.10 for the 35mm F1.4 lens, and for the XPro 1 body update from version 3.50 to version 3.70 but the camera cannot find either of these on my card when transferring to the camera. I did this one at a time, formatting the card between downloads, but cannot get them to work. Any suggestions please?

OK ALL DONE: the file name had been altered by the download and had to be revised.
Views: 99 / Likes: 0 / Replies: 3
Views: 95 / Likes: 7 / Replies: 4
Now that I'm back in Asia from sunny Southern California I am confronted with how to store my lenses and bodies in a very humid environment. The first couple months I used a box with desiccant and kept an eye on the humidity level with a hygrometer. I was able to get it down to 45%, but was having to replace or add to the desiccant every week or so.

Yesterday I was finally able to find a dehumidifier box. Got it home and moved all my equipment over to it. This morning the humidity in the box is at 37%! I couldn't be happier. The cost of the box, $US 185, is money well spent. Beats the cost of losing a lens or body to fungus.

Any best practices out there? I'm keeping the box in an area that is cooler than many areas of the house without air-conditioning so I can take out a body and lens and not have to worry about condensation forming on them.
Views: 140 / Likes: 0 / Replies: 6
I can't get AF+MF to work on my XE2. I can't tell if this is a lens issue with the new 23 f2 or a camera issue.

With AF+MF turned on and set to AF-S, nothing happens when I turn to focus the lens. Wondering if I'm doing something wrong here or it's not designed as expected.
Views: 158 / Likes: 0 / Replies: 3
hey guys! I have fuji xt1 and 35mm f2 wr, every time I hit play/browsing photo button, I heard aperture click sound then photo could show up, is this normal? Or I have a defective lens?
Views: 124 / Likes: 0 / Replies: 2
Views: 122 / Likes: 4 / Replies: 9