This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.

Instax SP-1 printer, flashing and non responsive

Discussion in 'Troubleshooting' started by Cb1, Jan 10, 2017.

  1. Cb1

    Cb1 New Member

    Joined:
    Jan 10, 2017
    Messages:
    2
    Likes Received:
    0

    -Return to Top-

    Hoping someone can help! My Instax SP-1 printer is having some issues. It was working fine, and then I replaced the empty film for a new one. It loaded normally and printed out the black top film, but then all the lights (battery, printing strip, number of photos left) started flashing green. They do not stop flashing, the printer does not respond to the on/off button. The batteries were fine (3 lights full green) so I am not sure what the issue is. I have tried removing and replacing the film in complete darkness. Once I close the back nothing changes. The flashing continues and it doesn't make any noise or seem to register that the film is there. I have had to remove the batteries to stop it from flashing. It's outside of it's year warranty so unfortunately fujifilm wouldn't be able to replace it. Any advice is greatly appreciated!
     
  2. pfogle

    pfogle Puzzled

    Joined:
    Nov 20, 2013
    Messages:
    1,046
    Likes Received:
    654
    Location:
    Auckland New Zealand

    -Return to Top-

    Have you tried another cartridge? Or putting the old one back in? If it still doesn't work, then it's the printer...
     
  3. Cb1

    Cb1 New Member

    Joined:
    Jan 10, 2017
    Messages:
    2
    Likes Received:
    0

    -Return to Top-

    Thanks for getting back to me! I tried putting in the old cartridge as you suggested, but the flashing continued and nothing changed. It was even flashing when the printer had no film in it at all. It's just strange because it was working completely fine but the effect was immediate once i put the new film in. Any other suggestions before I write it off as broken?

    Thanks
     
  4. mnflycaster

    mnflycaster Premium Member

    Joined:
    Nov 24, 2013
    Messages:
    637
    Likes Received:
    307
    Location:
    Minnesota USA

    -Return to Top-

    Even though the battery indicator show full bars it might be off. Are the batteries brand new?
    I had some batteries that were close to being done do the same thing to me. I replaced with new and all was well.
    I also had an issue once where a cartridge was bad. Replaced with a new one and all was well...
     

Share This Page