This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.

Fujifilm Instax Wide 300 Won't Print Photos Anymore

Discussion in 'Troubleshooting' started by CuppaTiwa, Jan 7, 2017.

  1. CuppaTiwa

    CuppaTiwa New Member

    Joined:
    Jan 7, 2017
    Messages:
    1
    Likes Received:
    0

    -Return to Top-

    After replacing the film cartridge for the first time, I took it with me to a nighttime concert. There I tried to take a photo, but it didn't come out. After turning off and on the camera a few times, it finally ejected. About two months later, I tried to take a second photo with the new cartridge during an early afternoon hangout. Just like last time... it didn't come out. Even after turning the power off and on multiple times, it NEVER ejected.

    I have no idea why this is happening, but my dad telling me I somehow damaged it while carrying it in my messenger bag; which is the bag I always had it in, cushioned by whatever flat object I carried behind it - usually my laptop. Should I take it somewhere to get it looked at, or is it just a teoubleshooting error I'm not aware of?
     
  2. Richard_R

    Richard_R Eclectic eccentric

    Joined:
    Dec 10, 2011
    Messages:
    6,111
    Likes Received:
    5,081
    Location:
    Melbourne, Australia

    -Return to Top-

    This is a Fuji X series camera forum so although there are likely to be some Instax owners on board I doubt that there is a lot of technical knowledge available for you.
    My suggestion is that as the Instax is a cartridge style camera and you are having trouble with photos ejecting from the cartridge I would first remove the cartridge that is in the camera and replace it with another one. You may simply have a faulty cartridge. If you do that and you still have problems then you will probably need to get in touch with Fuji directly in your country. Look up their support phone number on their local web site.
     

Share This Page